[Solved] MagicYUV blocked by Battleye  

Page 1 / 3
   RSS

0

Love the codec and use it all the time with Dxtory. One small issue is that it's now blocked by Battleye. If I try and record Rainbow6 gameplay, in Dxtory I just get the "!INT" warning, and when I drop out the game Battleye is telling me it's blocked MagicYUV.dll from loading. Was wondering if you were working with Battleye to get it unblocked, and if so how long does that kinda thing take?

Intel® Core™ i7-5960X @ 4.2GHz; Asus X99-Deluxe; 64Gb DDR4 Hyper X Fury @ 2133MHz; 256Gb 850 Pro; Titan X SC; Asus PG279Q; NZXT Kraken X61; Corsair AX1200i; SteelSeries Arctis Pro Wireless; Logitech G13; Logitech G900; Phanteks Enthoo Luxe; W10 x64

I got aware of the issue just recently, I'll contact Battleye about it and get back to you.

Awesome. Thanks. Trying to use other codecs but they are rubbish by comparison

Well, I wrote to Battleye on January 22, but no answer so far (except for an automated one with a ticket number). Maybe you should write to them too through their contact form, perhaps the more people rise the issue, the more likely they'll take notice.

38 Answers
0

Thank you once again!

It seems that they NOW resolved the issue. I can Record in Conan Exiles and in Rainbow Six Siege now.

Haven't tested it since you said you're going to ask them again.
So I have nothing changed since that time, just went into the games and it let me record without the BattlEye error messages from before.

Finally the best combination to record Lossless, DxTory 2.0.142 and MagicYUV 2.0.0rc2. BattlEye approved 😀

Getting around to test good settings can finally begin 😀

That's great to hear!

It took quite a while for this to get resolved, but in the end it was worth the wait I guess.

I think we finally close this issue now 🙂

1

Having similar problem with playerunknown's battlegrounds

Using Dxtory and MagicYUV 2.0.0 rc2

0

Got a reply from Battleye, they asked to see if I still experience the issue currently, so it might got resolved. Please check to see if it works now.

Hey Balazs

 

Thanks for replying and checking up with Battleye. Unfortunately, I've just tried again this morning, 10 Feb '17, have installed the latest updates for the game (so I have Velvet Shield installed) and also the latest UPlay updates, but I still get this error when trying to record with Dxtory and MagicYUV.

 

Drunk

I had a fairly quick response from Battleye as I raised another request with them. I've sent them a copy of the DLL that is being blocked. I'm using version 2.0.0 rc1 of MagicYUV and version 2.0.141 of Dxtory. So all the latest versions as far as I'm aware.

Hi Balazs

 

I got this reply from Battleye after I sent them the version of the DLL I have installed which is being blocked:

 

"Well, this is weird, since we already whitelisted a version with the exact same timestamp but a different size. Are there different versions of the same file? That would make it a bit hard to whitelist each version in the future."

 

I'm going to try downloading the Codec again, do you know if I'd have to pay again?

0

Any news from Battleye on this? I paid for the Ultimate edition as well, (2.0.0rc1), just to test and that's blocked by Battleye as well. Not sure what version of the codec they have whitelisted.

Intel® Core™ i7-5960X @ 4.2GHz; Asus X99-Deluxe; 64Gb DDR4 Hyper X Fury @ 2133MHz; 256Gb 850 Pro; Titan X SC; Asus PG279Q; NZXT Kraken X61; Corsair AX1200i; SteelSeries Arctis Pro Wireless; Logitech G13; Logitech G900; Phanteks Enthoo Luxe; W10 x64

I wrote to them again on February 10th, when they asked whether I still experience the issue. No answer since. I'll write to them again now, but to the looks of it, I'm not too confident that we'll have an answer...

 

EDIT: OK, I wrote to them, recommending to come up with a solution together (using digital signatures or any other mechanism), I'll let you know as soon as I get anything back from them.

Ok cool. Would be great to get Magic working through Dxtory. I struggle with other solutions like ShadowPlay or Mirillis Action. 

Out of curiosity, Dxtory itself is not blocked, only MagicYUV? Was this always the case? So that means that they whitelisted Dxtory somehow? Also, what if a new Dxtory edition comes out?

0

Yeah it's not Dxtory that is blocked but Magic. For example I can use Lagarith or Dxtory's own Codec to record. Battleye specifically states it's blocking "MagicYUV.dll" from loading. Other codecs in Dxtory are also being blocked, like UT. 

 

I'm not sure how or if they have specifically white listed Dxtory or what will happen when a new version of Dxtory comes out. Mirillis Action is also working (but you can't use VfW codecs in that), but Action releases regular updates and every update seems to work. Again not sure how this is achieved with Battleye I'm afraid. 

Intel® Core™ i7-5960X @ 4.2GHz; Asus X99-Deluxe; 64Gb DDR4 Hyper X Fury @ 2133MHz; 256Gb 850 Pro; Titan X SC; Asus PG279Q; NZXT Kraken X61; Corsair AX1200i; SteelSeries Arctis Pro Wireless; Logitech G13; Logitech G900; Phanteks Enthoo Luxe; W10 x64

It appears we might actually have something accomplished. It seems I'll just have to sign the codec DLL file the same way the installer is being signed, and then they could whitelist it forever. I'll get back as things go forward...

0

Awesome 🙂

Intel® Core™ i7-5960X @ 4.2GHz; Asus X99-Deluxe; 64Gb DDR4 Hyper X Fury @ 2133MHz; 256Gb 850 Pro; Titan X SC; Asus PG279Q; NZXT Kraken X61; Corsair AX1200i; SteelSeries Arctis Pro Wireless; Logitech G13; Logitech G900; Phanteks Enthoo Luxe; W10 x64

So BattlEye should be able to whitelist the new release (2.0.0rc2 and onward), I already wrote to them, I hope they'll get it added soon. Will get back if I hear from them and then you can test it.

0

Yeah... hope to see it being whitelisted soon. Can't wait to test it

Yeah just waiting for the Codec to be whitelisted. 

Unfortunately I still haven't received an answer back from them, but maybe you can test to see if it's still blocked?

0

Yeah it sadly is still blocked for me, whenever I hit the Record button it just pops-up the Battleye info box:

16:54:40: Starting BattlEye Service...
16:54:43: Launching game...
16:55:17: Note: File blocks can be ignored if they don't cause problems with the game.
16:55:17: [INFO] Blocked loading of file: "C:\Windows\System32\magicyuv.dll".

I wrote again, I'll notify you if I get back anything from them.

Awesome thanks. I get the same message as CryCel when I try and use Magic, (even after the update with the digital signature).

Well, it's their task to whitelist the cert, they said they'll whitelist it "shortly", so it'll be done shortly, whatever that means... 🙂

0

Thank you for contacting them again about this issue. Really hope it gets sorted soon too. Been recording alot and testing around alot in other games not using Battleye and I don't want to go back to other Codecs anymore :3.

0

I received an answer from them stating that it already should be whitelisted and asking what game did I test it in.

Could you all run a test again, making sure the game is fully updated as well as the codec being 2.0.0rc2?

Also, what games did you try it in? Maybe I can try to test as well.

0

Program: DxTory

Codec: MagicYUV 2.0.0RC2

Tested Games: Conan Exiles, Rainbow Six Siege, Arma 3, Unturned.

Games which give out the error: Rainbow Six Siege, Conan Exiles.

Error Report by Battleye:

12:18:44: Starting BattlEye Service... 

12:18:45: Launching game... 

12:20:10: Note: File blocks can be ignored if they don't cause problems with the game. 

 

12:20:10: [INFO] Blocked loading of file: "C:\Windows\System32\magicyuv.dll".

 

0

Same as CryCel for me. Tested with Rainbow 6 today, 30th March, and I get the same error as he does. R6 is the only game I have that uses Battleye so it's the only one I can test.

I completely uninstalled the previous version of MagicYUV using CCleaner and rebooted and then installed the new version. Attached is a screenshots showing the error I'm getting from Battleye.

EDIT - I'm using the correct version of MagicYUV 2.0.0 rc2 as you can see from the second screenshot

Intel® Core™ i7-5960X @ 4.2GHz; Asus X99-Deluxe; 64Gb DDR4 Hyper X Fury @ 2133MHz; 256Gb 850 Pro; Titan X SC; Asus PG279Q; NZXT Kraken X61; Corsair AX1200i; SteelSeries Arctis Pro Wireless; Logitech G13; Logitech G900; Phanteks Enthoo Luxe; W10 x64

0

Got a reply, they noticed the issue, said it will be fixed within the next few days. This was on April 1. so could you check if it works now?

0

Sadly still nothing on my end, Battleye still gives me the same message as before.
And DxTory stops at [Init].

08:53:40: Starting BattlEye Service...

08:53:42: Launching game...

08:54:22: Note: File blocks can be ignored if they don't cause problems with the game.

 

08:54:22: [INFO] Blocked loading of file: "C:\Windows\System32\magicyuv.dll".

Page 1 / 3
  
Working

Please Login or Register