Notifications
Clear all

[Solved] Playing MagicYUV files in VLC media player?

   RSS

0
Topic starter

VLC cannot decode and play videos I record in Dxtory using MagicYUV codec. I'd really like to make it work in VLC instead of windows media player, but I don't know how to  do this. Any help?

5 Answers
0

Update to MagicYUV 2.0.0 final. The VLC 3.0.x plugin was not yet available for 2.0.0rc2 and was added for 2.0.0 final. You can read more about it here: https://www.magicyuv.com/change-log/

You can download the update from the same link you got when you purchased the rc2 version.

I resent the receipt. Check your spam folder too and get back to me if you received it.

0

You need to have the MagicYUV VLC plugin installed inside the VLC plugins folder. Install VLC to the default location, the re-install the MagicYUV codec. During installation, it will notify you of the VLC plugins being installed.

Could you verify the MagicYUV decoder plugin is loaded by VLC? To do so, go to "Tools -> Plugins and extensions" then in the dialog select the "Plugins" tab, and search for "MagicYUV video decoder".

0

Where do you have VLC installed?

What version of VLC are you using?

What version of MagicYUV are you using?

0

Hi - some years ago I transcoded all of my old files to magicyuv.  Recently I rediscovered them but a fresh install of VLC and a fresh install of MagicYUV is not working.  Gives the 'M8Y4' error. 

 

VLC:  3.0.16 Vetinari

MagicYUV:  2.3.1 standard

I copied the x86 dll from the installed path, to the codec dir in the vlc installed dir.  When I run VLC, however, it does not list the plugin as loaded.  Any assistance would be absolutely appreciated!

0

Simply reinstall the codec using the installer, it will copy the correct DLL depending on VLC version and compiled VLC architecture (32/64-bit). This only works if VLC is installed in the default location.

For manually copying the DLL you need to copy the correct one. That depends on VLC version and whether the VLC you have installed is 32 or 64 bits. For 64 bits, you need to copy from the x64 subdir, for 32 bits you need to copy from the x86 subdir.

Thank you Balazs. Unfortunately space is limited on my boot SSD so I install applications to my D drive. Installed path for VLC is D:\Program Files\VideoLAN\VLC\ I installed VLC from a binary called "vlc-3.0.16-win64.exe" I copied the dll from my installed MagicYUV path "Program Files (x86)\MagicYUV\VLC\3.0.x\x86". File size is 865,792 bytes 10/26/20. The path in my MagicYUV install directory does not appear to have a 64bit branch.

That is not going to work, as the plugin in the "x86" dir is the 32-bit VLC plugin. There must a folder "x64" next to the x86 one, you say it is not there? In that case try reinstalling the codec with all components and get back to me.

Balazs - Thank you so much! Problem exists between chair and keyboard: I blinded myself to exclude that directory assuming it corresponded to an AMD-specific binary versus Intel. It was indeed there, and does indeed now work. Thank you very much!