No Green Icon in Sy...
 

[Solved] No Green Icon in System Tray When Using MPC-HC/BE  

  RSS

Trevor
(@trevor)
Active Member
Joined: 6 months ago
Posts: 5
07/11/2019 8:58 pm  

The title pretty much explains my problem. How do I get MPC-HC or MPC-BE to use the official decoder? When I play the file in VirtualDub2 the green icon shows. I am on the latest version of everything. I've tried uninstalling and reinstalling and I left the "disable internal decoder" (or something like that) option checked.


Quote
Balázs
(@ignus)
MagicYUV Author Admin
Joined: 3 years ago
Posts: 181
07/11/2019 9:10 pm  

Tell me the exact versions of both MPC-HC and MPC-BE.

Unfortunately both use different settings, and as I recall they don't even allow only MagicYUV decoding to be disabled  but instead it's bundled together into the "lossless" category. It's super frustrating.

What the installer tries to do is set some registry values which supposedly refer to those settings, but those are not officially documented or anything, so it's possible that they change between versions.


ReplyQuote
Trevor
(@trevor)
Active Member
Joined: 6 months ago
Posts: 5
07/11/2019 9:15 pm  

@ignus

MPC-HC 1.8.8.14 installed as part of K-Lite Standard 15.2.4

MPC-BE 1.5.4 build 4850

MagicYUV Ultimate 2.2.0

This post was modified 1 week ago 2 times by Trevor

ReplyQuote
Balázs
(@ignus)
MagicYUV Author Admin
Joined: 3 years ago
Posts: 181
08/11/2019 12:13 pm  

I tested both, and MPC-HC seems to have no built-in MagicYUV decoder, and for MPB-BE, the installer setting works, so I guess something else is interfering on your machine. It could be the LAV decoders installed by the codec pack or something else (codec packs can really wreak havoc in this area).

I'd suggest you check in MPC-BE the filter graph built and see which component does the decoding.


ReplyQuote
Trevor
(@trevor)
Active Member
Joined: 6 months ago
Posts: 5
08/11/2019 12:49 pm  

On the system tray, while playing a MagicYUV video, there was a red icon called “LAV.” After opening it and unchecking “MagicYUV video” under “Formats” I now have a green icon for both MPC-HC and MPC-BE. However, I was hoping that it was my playback that wasn’t 60 FPS because of the wrong decoder; now I know for sure it’s the capture itself that isn’t 60 FPS. CPU utilization is reduced by over half when using the official decoder.

Thanks for looking into it.

This post was modified 7 days ago by Trevor

ReplyQuote
Balázs
(@ignus)
MagicYUV Author Admin
Joined: 3 years ago
Posts: 181
08/11/2019 1:04 pm  

No problem, thanks for the info. Though the LAV filter should also be disabled by the installer, could you tell the LAV version too, so I can check? Thanks.


ReplyQuote
Trevor
(@trevor)
Active Member
Joined: 6 months ago
Posts: 5
08/11/2019 1:06 pm  

0.74.1.30-git


ReplyQuote

Please Login or Register