Notifications
Clear all

[Solved] Magix Movie Edit Pro

3 Posts
2 Users
1 Likes
24.2 K Views
0
Topic starter

I've purchased and have been using MagicYUV for a while now, and I've been very happy with the results. However, I'm running into a problem using the codec with the Magix Movie Edit Pro video editor. Trying to add a video encoded using MagicYUV gives me the following error (in the details):

please install the following codec to decode the format 'M8Y0'.

So it doesn't seem to be able to use the codec. I'm not entirely sure, but I don't think I encountered this problem with previous versions of the software. Any help would be appreciated!

Balázs Balázs 22/02/2017 12:36 am

That is strange. I assume you use version 2.0.0rc1 of the codec? Does it load in any other software (like VirtualDub, Media Player, etc. with the green tray icon being visible)?

Also, could you check "Decompression settings..." in the global MagicYUV VFW Configuration, it might be that decoding MagicYUV YUV 4:2:0 (M8Y0) as RGB is disabled?

1 Answer
1
Topic starter

Thanks for suggesting the decompression settings, those were indeed the cause. It was working in Virtualdub, but I assume Magix requires the codec to output in RGB? I should have heeded the warning and left those settings alone. Basically the reason I changed them is to try and avoid unnecessary colorspace conversion taking place in, for example, Avisynth. If I'm not mistaken, if I don't disable RGB, it ends up using that in Avisynth instead of the original colorspace.

Balázs Balázs 22/02/2017 1:04 am

Yes, most pro editing software only accept/request RGB from codecs (including Magix Movie Edit, Vegas, Adobe After Effects, etc.), so the codec must do internal conversion.

About Avisynth: if you look at the tooltip of the button "Set defaults" in "Decompression settings...", you'll see the order in which Avisynth requests pixel formats from the codec (I believe it didn't change since). So it should try YV12 first before RGB, avoiding conversion. However, the reason why YUV 4:4:4 conversion output is disabled for the defaults is because Avisynth tries YV24 before YV12 (which is dumb), so it would always request the codec to convert YUV 4:2:0 to YV24, and so the defaults avoid that conversion.

About the warning: Well, maybe it's not scary enough, I'll think about something for the next release 😉