Notifications
Clear all

[Solved] Any way to trandcode MagicYUV with Handbrake or another tool?

   RSS

1
Topic starter

Hey all! I've been using Lagarith to record lossless footage for YouTube videos for a while but I really like a lot about MagicYUV, particularly how much faster it performs when editing in Vegas Pro. However, I have one major problem and I'm hoping someone knows a solution to it. I keep archives of all my projects and footage but I simply don't have the storage to keep the amount of footage I record in a lossless form indefinitely. What I do right now is once the project is complete and on YouTube, I transcode the lossless footage into a lossy MP4 with Handbrake. The quality obviously goes down but the file size drops by like 80% and the quality is still good enough to use for archival purposes.

The problem of course is that, Handbrake won't convert MagicYUV. I can't remember the term but I read this is because it's not in the big batch of codecs that Handbrake supports. The lack of being able to transcode for archiving is the only thing preventing me from using MagicYUV for all my videos going forward, which I would really like to do. Is there any way I could make Handbrake or another transcoding solution work with this to accomplish the same task? Thanks, keep up the great work!

9 Answers
2
Topic starter

I'm beyond thrilled to say that in the newly released v1.7.0 of Handbrake, this issue has been FIXED! The funny part? Despite my going back and forth with the devs on it and having sent them over 70GB of test footage, this seems to have been fixed by accident. Their lead dev had an idea what was up but hadn't gotten to it yet. However, in fixing another bug that was tangentially related, they seemed to have fixed this one too. I loaded up a clip that previously wouldn't open in Handbrake and it opened and transcoded perfectly. They asked me to send logs so they can see how it's been fixed but yeah, all good now! Happily using MagicYUV for all my YouTube projects going forward!

That is great to hear! Do you have a link to the fix, and what was the core of the issue?

Rodeo (one of the developers who I've been working with on this) asked me to send him a log that he could analyse (which I've done) but he believes this issue's fix might have been caught up in this bug fix for something else.

Ha, that's funny, if that really fixed it 🙂 Anyway, thx.

1
Topic starter

So I wanted to let everyone know something cool. I didn't realise but Handbrake actually went v1.0 recently. For whatever reason, the application's internal update function didn't notify me of this but I found out from their web site. They've made a number of changes, one of which is that it will recognise and transcode MagucYUV 2.0 videos! Needless to say, this makes me very happy. 🙂 If anyone wants to transcode down lossless footage for archiving, Handbrake makes it easy. Thanks and keep up the great work!

1

Well, this is the area where others, especially gamers might have more experience, and something I'd like to know better myself.

ffmpeg can decode MagicYUV files (albeit slower), so that's an option.

I think HandBrake uses ffmpeg under the hood, but a hard-copy one (I mean a hard-copy of the ffmpeg sources right inside HandBrake), which is probably a version which doesn't have MagicYUV decoding support.

Another option might be x264gui along with avisynth. https://sourceforge.net/projects/x264gui/

Thanks for the comments! 🙂

1
Topic starter

I hadn't come across x264gui before but that looks like it might be a good option. I have no particular attachment to Handbrake, it's just easy to use and supports multiple audio tracks, which I wanted. I'll give x264gui a shot and see what it does. Thanks!

1
Topic starter

So I may have spoken a bit too soon. I'm curious if anyone knows why this might be. Tonight, I recorded two different videos using MagicYUV. One was about 20 minutes and 57GB, the other was about 40 minutes and 126GB. I was able to transcode the smaller file using HandBrake but the bigger file won't read in it. It says that it's not a valid source file. However, it opened and was able to be edited in Vegas Pro with no problems. I'm not sure why this would be as when I was using Lagarith, I was able to transcode files of this size and larger without issue. Any ideas? Thanks!

The decoder in Handbrake is from ffmpeg (not official), it might croak for some reason.

Could you try with a small portion of it? You can use VirtualDub in "Direct stream copy" mode and make a smaller AVI to see if the problem is because of the size of the AVI (muxing problem) or because of the compressed data.

1

Handbrake actually *can* read, and encode, MagicYUV files. The real problem, however, seems to be what recording program captures these files.

MagicYUV files recorded by Dxtory, for instance, *can't* be read by Handbrake. If you, then, however, re-encode them with the same codec settings via Adobe Media Encoder; Handbrake can read/encode it just fine.

Bandicam recorded files work fine with Handbrake by default. (Though it does corrupt 100GB+ files)

So every program isn't created equally, it seems.

 

1
Topic starter

Which is really strange. I figured the codec just told the recording software how to write the file and that was that. I record both in Dxtory and Bandicam and have not had consistent results. Sometimes files from both won't encode, sometimes they do, sometimes 100GB+ files don't work, sometimes they do. The inconsistency is what makes no sense to me.

1
Topic starter

I've given this additional information to the Handbrake forums. One of the developers was reading my thread on this issue there and responded once but hasn't recently. Is this worth bringing up with the authors of Bandicam and Dxtory? Unfortunately, support for both of those applications is notoriously bad (Bandisoft regularly just dismisses complaints as not their problem and Excode just tends to ignore people) but I'll try to push it with them if it seems the problem is on their side and not either Handbrake's or MagicYUV's.

To add some info here:

Bandicam corrupts the AVI index over a certain size, more here:  https://www.magicyuv.com/community/help-support-troubleshooting/magicyuv-2-0-0rc1-corrupt-my-file-because-is-very-big/#post-150

Dxtory should work fine in general, I haven't had any reports so far it corrupting AVI files. Maybe if someone experiencing issues with Dxtory-recorded MagicYUV files that refuse to load in Handbrake could send me a file, so I can take look.

About the support situation regarding Dxtory: it's impossible to reach anyone there (developer that is), no answer either on the forums or through direct email, I also tried for various reasons, no luck so far...

Yeah, it's really frustrating. English is not the developer's first language but that hasn't stopped him from occasionally providing support in the forums. And frankly, it isn't an excuse. If you're charging money for a product (and not an insubstantial amount), expecting support isn't out of line.

Dxtory has been getting more and more flaky in general lately and I've been leaning more into Bandicam. Of course, it has its own issues as you stated and their support tends to consist of them having you try a couple of basic things and then just saying "We don't know what's wrong, good luck." I once asked them why a very expensive capture card I have worked in every other application but not Bandicam. Their answer after "Try other drivers" was "We don't know why it's not working but have no plans to work on this further." Sadly, these products don't have much competition and they know it.

1
Topic starter

I have a file available that I made this morning in Dxtory that refuses to open in Handbrake. It's 43.2GB though. What's a good way for me to get that to you?

The best would be through Google drive or something similar. But please don't use mega, it's a pain to download from there.

If you don't have enough cloud storage, than maybe I can provide some, but if you can upload somewhere and send me the link through the contact form, that would be the best.

 

(A side note: use the "Add a comment" button to add a comment instead of an answer to the topic if that's your intent)

 

(EDIT: Yeah, I know the forum engine is still new and a bit confusing to use...)

Ahh, didn't notice Add a Comment. Sorry about that.

Crud, I was going to suggest MEGA as I actually use them and they're the only service I have access to with that much space available. My Google Drive only has 17GB total. You're right though, I believe MEGA has a transfer limit that would prevent you from being able to download a single file that large. I do have my own home server and could quickly setup a FileZilla server on it that you could FTP the file from if you want. I only have 10Mbit upload on my connection so it will take a number of hours but if you're OK with that, I'm happy to set that up.

PM me if you want to go that route, otherwise, do you know of another service that would accept a file this big?

Oh well, guess it'll be mega then 🙂

 

I actually bought a month of mega for getting the stuff from Cloudstrifeff7, but even then it sometimes dropped to very slow speeds, sometimes errored out with some HTML storage full errors, had to delete cookies, it was a true pain to use.

 

Anyway, just upload to mega then and send me the links through PM, I still have enough bandwidth there for some time.